Azure下的Linux在安装GNOME桌面及VNC的时候,会有

--> Finished Dependency Resolution

Error: WALinuxAgent conflicts with 1:NetworkManager-0.8.1-66.el6.x86_64
You could try using --skip-broken to work around the problem
** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:

或者类似错误,直接带上--skip-broken参数就可以了:

yum --skip-broken groupinstall "GNOME Desktop" "Graphical Administration Tools" -y
yum --skip-broken groupinstall "X Window System" "Desktop" -y

参考:https://blogs.msdn.microsoft.com/faber/2014/10/16/how-to-install-vnc-in-azure-oracle-linux-vm/

带符号 * 的表示必填项